1977 F30 318 cuts off under load

This forum is for comments and the exchange of information relating to Trojan Boats and boating. Please do not post used parts or boats For Sale in this area. For general, non-boating topics please use our "General Discussions" section.

Note: Negative or inflammatory postings will not be tolerated.

Moderators: BeaconMarineBob, Moderator, BeaconMarineDon

User avatar
Martino
Registered user
Posts: 26
Joined: Sat Dec 02, 2017 8:07 am
Location: Detroit Michigan

1977 F30 318 cuts off under load

Post by Martino » Wed Apr 25, 2018 7:58 am

So my starboard engine cuts off trying to get up on plane when I apply the throttle.
Any advise and thoughts would be greatly appreciated !

User avatar
Lance F28
Registered user
Posts: 41
Joined: Fri Aug 04, 2017 11:04 am

Re: 1977 F30 318 cuts off under load

Post by Lance F28 » Wed Apr 25, 2018 4:24 pm

Check your fuel filter. You may have enough flow to idle, or run at low RPMs but it may be starving for fuel under power. When I first purchased my 79 F28 with twin 318's my port side motor picked up some trash from the tank and it would barely run 2500-3000 RPM. I replaced the fuel filter and installed a second cheap inline filter between the water separator and the fuel pump so I could intercept any more debris from that tank. I had to change that filter twice and since then I haven't had any problems.

User avatar
captainmaniac
2018 Forum Supporter
2018 Forum Supporter
Posts: 1789
Joined: Sat Apr 30, 2005 10:26 pm
Location: Burlington, Ontario

Re: 1977 F30 318 cuts off under load

Post by captainmaniac » Wed Apr 25, 2018 7:40 pm

Agree re the filters, or possibly float or choke issue.

I also once had an issue with distributor not advancing but symptoms are different - couldn't climb above a certain RPM, but engine didn't quit.

User avatar
oldboat1
2018 Forum Supporter
2018 Forum Supporter
Posts: 108
Joined: Fri Mar 04, 2011 4:48 pm
Location: Penn Yan, NY

Re: 1977 F30 318 cuts off under load

Post by oldboat1 » Wed Apr 25, 2018 10:52 pm

Water separating filter? May need to empty the canister.

Might do a compression check.
Motors should run. People -- not so much.

1980 F26, Mercruiser 305
1979 14' Starcraft, 1957 18 hp Evinrude and '57 3hp Evinrude kicker

User avatar
Paul
2018 Forum Supporter
2018 Forum Supporter
Posts: 1140
Joined: Fri Jun 10, 2005 1:02 pm
Location: Windsor Ont.

Re: 1977 F30 318 cuts off under load

Post by Paul » Thu Apr 26, 2018 7:25 pm

Might want to check the anti-syphon valve at the suction tube on top of the tank. Since it's before the filter, debris tends to get caught up in it and can reduce fuel flow. I experienced this exact problem and the symptoms were that I could run all day under 1800 rpm however as soon as I got on plane at 3200 the fuel bowl would go dry and the boat would go dead in the water. A little cranking and she'd fire back up and let me run up to 1800 rpm again.

Hope this helps.
Paul
"Cruise Control" 1978 F-26HT
"No Control" 2012 9' Grand RIB

User avatar
AlphaJustin
Registered user
Posts: 78
Joined: Thu Jun 22, 2017 11:26 am
Location: Syracuse, NY

Re: 1977 F30 318 cuts off under load

Post by AlphaJustin » Fri Apr 27, 2018 10:58 pm

Mine does that when the fuel filter isn't sealed and let's air in the line. Runs perfect unless you run 3/4 to full throttle then it just shuts off I've gotten used to popping the hatch and adjusting the filter then a couple cranks later and fires right back up good to go.
1972 Trojan F-25 with no TRJ number and a 4 barrel

User avatar
Martino
Registered user
Posts: 26
Joined: Sat Dec 02, 2017 8:07 am
Location: Detroit Michigan

Re: 1977 F30 318 cuts off under load

Post by Martino » Sat Apr 28, 2018 7:32 am

I replaced the fuel filters and still the same problem.
Is the anti siphon valve in the hard fuel line going from the fuel tank to the fuel crossover valve ?

User avatar
prowlersfish
2018 Forum Supporter
2018 Forum Supporter
Posts: 11164
Joined: Sat Nov 05, 2005 6:56 pm
Location: Lower Chesapeake Bay ,Va

Re: 1977 F30 318 cuts off under load

Post by prowlersfish » Sat Apr 28, 2018 8:16 am

Its normally right at the tank fitting
TROJAN F36 Conv.
6BTA Cummins diesels
Life is to short for a ugly boat :D
2009 TROJAN RENDEZVOUS
Port Kinsale 2010 & 2011. Solomons get together 2011.

User avatar
Martino
Registered user
Posts: 26
Joined: Sat Dec 02, 2017 8:07 am
Location: Detroit Michigan

Re: 1977 F30 318 cuts off under load

Post by Martino » Mon May 07, 2018 8:42 am

So the suspected Anti Siphon Valve was glogged !

User avatar
Paul
2018 Forum Supporter
2018 Forum Supporter
Posts: 1140
Joined: Fri Jun 10, 2005 1:02 pm
Location: Windsor Ont.

Re: 1977 F30 318 cuts off under load

Post by Paul » Mon May 07, 2018 10:13 am

Ok, glad that you found the problem. Now for the root cause; What was it clogged with? Does the tank need to be flushed?
Paul
"Cruise Control" 1978 F-26HT
"No Control" 2012 9' Grand RIB

User avatar
Martino
Registered user
Posts: 26
Joined: Sat Dec 02, 2017 8:07 am
Location: Detroit Michigan

Re: 1977 F30 318 cuts off under load

Post by Martino » Mon May 07, 2018 12:30 pm

It looked like brown crud and spiders

User avatar
Martino
Registered user
Posts: 26
Joined: Sat Dec 02, 2017 8:07 am
Location: Detroit Michigan

Re: 1977 F30 318 cuts off under load

Post by Martino » Mon May 28, 2018 10:48 pm

So the engine still intermittently cuts off and when I raise the rpm level it wants to intermittently lower and raise itself. Also when the starboard engine is running and I go to start the port engine the starboard engine cuts off. I'm stumped now.
Any more advise and help?

User avatar
Big D
Ultimate User
Posts: 2821
Joined: Sat May 01, 2010 10:39 pm
Location: Ontario, Canada

Re: 1977 F30 318 cuts off under load

Post by Big D » Tue May 29, 2018 6:32 am

The wondering rpm sounds like you still have a fueling issue. An running engine quitting when you start the other engine is an electrical issue; poor/ corroded/loose connections or weak batteries. If there's an internal issue or problem with the starting on the engine you're starting last, it could be drawing way more power at start up than normal. Does this happen no matter which engine is started first?
1969 36 ft wooden beauty with big blue 440s
And thanks to the gang, 2012 Trojan Boater Of The Year

User avatar
Martino
Registered user
Posts: 26
Joined: Sat Dec 02, 2017 8:07 am
Location: Detroit Michigan

Re: 1977 F30 318 cuts off under load

Post by Martino » Tue May 29, 2018 8:01 am

Big D wrote:
Tue May 29, 2018 6:32 am
The wondering rpm sounds like you still have a fueling issue. An running engine quitting when you start the other engine is an electrical issue; poor/ corroded/loose connections or weak batteries. If there's an internal issue or problem with the starting on the engine you're starting last, it could be drawing way more power at start up than normal. Does this happen no matter which engine is started first?

The starboard engine only cuts off when I start the port engine. But if the RPM's are up on the starboard engine it doesn't cut off.
Im going to investigate all connections with the batteries and drain the water separator canisters to get a look at the fuel.

User avatar
Martino
Registered user
Posts: 26
Joined: Sat Dec 02, 2017 8:07 am
Location: Detroit Michigan

Re: 1977 F30 318 cuts off under load

Post by Martino » Thu May 31, 2018 11:12 pm

Checked all the battery cables and found nothing out of the ordinary. However, I have to start the starboard engine first and keep it's RPM's above 1000 in order to start the port engine without the starboard engine stalling.
If the port engine is running first and I try to start the starboard engine it just cranks but won't kick over. If the port engine isn't running the starboard engine does start.
Ok this is really a pain in the Butt
Last edited by Martino on Tue Jun 26, 2018 6:51 am, edited 1 time in total.

Post Reply