No Fuel Drawing From Tanks

This forum is for comments and the exchange of information relating to Trojan Boats and boating. Please do not post used parts or boats For Sale in this area. For general, non-boating topics please use our "General Discussions" section.

Note: Negative or inflammatory postings will not be tolerated.

Moderators: BeaconMarineBob, Moderator, BeaconMarineDon

Post Reply
tonydelgreco
Registered user
Posts: 20
Joined: Mon Apr 23, 2018 9:24 am

No Fuel Drawing From Tanks

Post by tonydelgreco » Mon Jul 23, 2018 10:32 am

I swapped my tanks over last weekend to the last full tank. I got the boat last August and filled all 4 before making the trip to my marina. Ran the boat at dock for about 15 minutes and away I went. I got about 10 minutes into the trip at headway speed only, and powered up. After a couple minutes at 2500 rpm's motors stated to cut out. Started up again and off I went another minute or so and same thing happened. At this point only the starboard engine would run. Seeing we where going to stay in the river we continued running on 1 engine for a couple hours (tried starting port side a couple times). Got back to the marina tried starting port and it fired up and I was able to bring the boat to dock without incident. Water in Fuel? Yes changed both water separators and inline fuel filter to port motor. Port separator had some water and sediment, starboard had a little sediment but did not notice water (this motor ran all day off same tank as port that died). OK problem fixed? NO! Here is where it gets tricky. Tried starting port motor without filling water separator with fuel, no dice. The next day I changed the other separator and filled both with fuel and port fired up not so lucky with starboard (the one that ran all day). Took separator off no fuel, filled again with fuel pulled line in front of filter at carburetor and it is pumping gas. Fired up port again (still cant start starboard) ran rpm's up and it died again. Now I pull both water separators off and both are empty so I'm not drawing fuel from the tank? Where did I go wrong? I have no idea, can someone help??? Thank you.

Tony

User avatar
Reel Easy
Sporadic User
Posts: 123
Joined: Sun Nov 30, 2014 11:01 pm
Location: Akron, Ohio

Re: No Fuel Drawing From Tanks

Post by Reel Easy » Mon Jul 23, 2018 10:13 pm

Try cleaning the one way check valve. It looks like a brass coupling located close to the tank outlet. Also check the vents are clear of spider webs or other foreign matter.
Dustin
78 F-32 Express Hard top twin 360s
Catawba Island, Ohio

tonydelgreco
Registered user
Posts: 20
Joined: Mon Apr 23, 2018 9:24 am

Re: No Fuel Drawing From Tanks

Post by tonydelgreco » Wed Jul 25, 2018 7:22 am

Thank you, I will check them but probably not the problem. I tried drawing off more than 1 tank.

Tont

mikeandanne
Moderate User
Posts: 550
Joined: Sun Sep 09, 2012 11:30 am

Re: No Fuel Drawing From Tanks

Post by mikeandanne » Wed Jul 25, 2018 7:50 am

Sounds like you may have air getting in from somewhere, that will defeat any fuel pump. Look along the fuel lines going back to the tanks for anything teed into the lines, check valves and fittings for tight, if you have a generator, where does the fuel line come from for it, are the empty tanks and generator isolated from the system now ?
78 F 32

User avatar
Paul
2018 Forum Supporter
2018 Forum Supporter
Posts: 1141
Joined: Fri Jun 10, 2005 1:02 pm
Location: Windsor Ont.

Re: No Fuel Drawing From Tanks

Post by Paul » Wed Jul 25, 2018 9:51 am

Reel Easy wrote:
Mon Jul 23, 2018 10:13 pm
Try cleaning the one way check valve. It looks like a brass coupling located close to the tank outlet. Also check the vents are clear of spider webs or other foreign matter.
I would bet that this is the problem as we've seen it happen to several members on this site over the years. Clearing the check valve is the easy part, keeping it from reoccurring can be tough. Sometimes it involves flushing out the tanks, other times it requires replacing them.

Keep us posted on what you find.
Paul
"Cruise Control" 1978 F-26HT
"No Control" 2012 9' Grand RIB

tonydelgreco
Registered user
Posts: 20
Joined: Mon Apr 23, 2018 9:24 am

Re: No Fuel Drawing From Tanks

Post by tonydelgreco » Wed Aug 01, 2018 10:50 am

Thanks all. Got it. Was simply the O rings on both separator canisters. Actually got a couple new O-rings off a friend at the marina. Here is a great tip, took them off new Fram oil filters. The O-rings that came with the new cartridges where slightly to large and I cut them when installing. The Fram oil filter o-ring was a little snug but with some motor oil it went on smoothly. Still have water in the tank though, port cut out after 20 minutes, will add another 30 oz of K-100 and see if it helps.

Tony

Post Reply