Burning out coils??

This forum is for comments and the exchange of information relating to Trojan Boats and boating. Please do not post used parts or boats For Sale in this area. For general, non-boating topics please use our "General Discussions" section.

Note: Negative or inflammatory postings will not be tolerated.

Moderators: BeaconMarineBob, Moderator, BeaconMarineDon

Post Reply
User avatar
bigrgh
Registered user
Posts: 53
Joined: Wed Nov 11, 2009 6:12 pm
Location: Point Judith R.I.

Burning out coils??

Post by bigrgh » Fri Nov 09, 2018 5:14 pm

Went for a ride last week, starboard engine dies.
After diagnosis, coil not coiling.
Back to dock on one engine and new coil, wires set and ballast resistor... fires right up.. yay!
Today go out fishing, same engine dies almost same place. Coil got no spark. Tie up to bait dock, go to parts store get another new coil. Check all wiring and connections. All looks good
Put coil on, head back to my slip. Engine dies within sight of it. Any suggestions on why I’m frying the coil?? 1984 454 model 350 crusader
Any help appreciated
Slippery When Wet
84- 10meter

User avatar
prowlersfish
2018 Forum Supporter
2018 Forum Supporter
Posts: 11270
Joined: Sat Nov 05, 2005 6:56 pm
Location: Lower Chesapeake Bay ,Va

Re: Burning out coils??

Post by prowlersfish » Fri Nov 09, 2018 6:12 pm

Check voltage at coil . cheap coils or wrong coil ?
TROJAN F36 Conv.
6BTA Cummins diesels
Life is to short for a ugly boat :D
2009 TROJAN RENDEZVOUS
Port Kinsale 2010 & 2011. Solomons get together 2011.

User avatar
Bob Giaier
Sporadic User
Posts: 196
Joined: Thu Sep 17, 2009 12:42 pm
Location: Clarkston, Michigan

Re: Burning out coils??

Post by Bob Giaier » Sat Nov 10, 2018 8:07 am

How about wrong ballast resister or the resister is being bypassed after the engine is started allowing the coil to overheat. I believe it's only bypassed to start the engine so you get a hotter spark to start. Maybe you have it switched.
Just thinking

Stella365
Registered user
Posts: 1
Joined: Fri Nov 16, 2018 1:45 pm

Re: Burning out coils??

Post by Stella365 » Fri Nov 16, 2018 1:49 pm

The same thing happened to me. Turns out it was the wrong coil.

Post Reply