problem

This forum is for comments and the exchange of information relating to Trojan Boats and boating. Please do not post used parts or boats For Sale in this area. For general, non-boating topics please use our "General Discussions" section.

Note: Negative or inflammatory postings will not be tolerated.

Moderators: BeaconMarineBob, Moderator, BeaconMarineDon

Post Reply
User avatar
lasker
Registered user
Posts: 40
Joined: Fri May 04, 2012 2:50 pm
Location: perry lake kansas

problem

Post by lasker » Mon Sep 09, 2019 9:50 am

start both engines go anchor out..turn off engines..4 hours..go to start..starboard starts port not even with emg start won't even move move dash gauges .. no cabin interior lights..4 miles on one engine and can emg start port...back in slip turn off engines .port will not start without emg start ..no cabin lights....maybe battery charger..1979 321
1979 321 Trojan

User avatar
prowlersfish
2019 Gold Support
2019 Gold Support
Posts: 11677
Joined: Sat Nov 05, 2005 6:56 pm
Location: Lower Chesapeake Bay ,Va

Re: problem

Post by prowlersfish » Mon Sep 09, 2019 12:58 pm

Check/test the port battery . Check connections and cables
TROJAN F36 Conv.
6BTA Cummins diesels
Life is to short for a ugly boat :D
2009 TROJAN RENDEZVOUS
Port Kinsale 2010 & 2011. Solomons get together 2011.

User avatar
lasker
Registered user
Posts: 40
Joined: Fri May 04, 2012 2:50 pm
Location: perry lake kansas

Re: problem

Post by lasker » Mon Sep 09, 2019 1:28 pm

thanks its a start.
1979 321 Trojan

Post Reply