Aquatemp A/C compressor running nonstop

This forum is for comments and the exchange of information relating to Trojan Boats and boating. Please do not post used parts or boats For Sale in this area. For general, non-boating topics please use our "General Discussions" section.

Note: Negative or inflammatory postings will not be tolerated.

Moderators: BeaconMarineBob, Moderator, BeaconMarineDon

Post Reply
Blueflu
Registered user
Posts: 33
Joined: Sun Mar 06, 2016 4:33 am

Aquatemp A/C compressor running nonstop

Post by Blueflu » Thu Mar 30, 2017 6:18 pm

Has anyone come across this issue. I have an 85 10 meter express. I just put the boat in for the season and turned the AC breaker on and before I hit the cabin controls the compressor kicked in. Regardless of what I do it won't turn off unless I kill the breaker. The unit works, blowing air but not getting warm, I assume because of the water temperature, water pumping, fan speed controls ok but when I turn the power off from the thermostat the unit powers down but the compressor stays on until I hit the breaker. I'm also hearing a woosh sound when I turn the tstat controls on and off that I don't remember hearing last year.

Thanks for any input.

User avatar
prowlersfish
2018 Forum Supporter
2018 Forum Supporter
Posts: 11091
Joined: Sat Nov 05, 2005 6:56 pm
Location: Lower Chesapeake Bay ,Va

Re: Aquatemp A/C compressor running nonstop

Post by prowlersfish » Fri Mar 31, 2017 6:58 am

Sounds like you may have a stuck relay or a bad board . What system do you have ?
TROJAN F36 Conv.
6BTA Cummins diesels
Life is to short for a ugly boat :D
2009 TROJAN RENDEZVOUS
Port Kinsale 2010 & 2011. Solomons get together 2011.

Blueflu
Registered user
Posts: 33
Joined: Sun Mar 06, 2016 4:33 am

Re: Aquatemp A/C compressor running nonstop

Post by Blueflu » Fri Mar 31, 2017 8:09 am

I know it's an Aquatemp non-split system. Data plate is unreadable. The reset button had to be reset last season almost on a regular basis when I'd get to the boat and turn on the AC and this year when I turned it on I had to reset it as well. When I did so it seemed a little crusty, not smooth when I pushed it in. I took the cover off in the engine room and it does look like I've got some discoloration on the surfaces of the electrical contacts and the outer surface of what I assume is some kind of relay. The capacitor looked like new. I'm really new to this boat AC stuff.

User avatar
Lou
Registered user
Posts: 31
Joined: Sat Aug 02, 2014 3:17 pm
Location: Hampton Roads

Re: Aquatemp A/C compressor running nonstop

Post by Lou » Fri Mar 31, 2017 10:18 am

AC guy by trade here. Your contactor may be shot or it could be your thermister.

When you kill the breaker and turn it back on, does the AC still come on or do you ave to turn the ac switch back on?
1972 - Trojan F31
1981 - Grady White Sailfish 25
1988 - Wellcraft 2800 Express
1966 - Chris Craft 36'

Blueflu
Registered user
Posts: 33
Joined: Sun Mar 06, 2016 4:33 am

Re: Aquatemp A/C compressor running nonstop

Post by Blueflu » Sat Apr 01, 2017 9:14 am

Haven't tried that this year. Presently if I shut the AC off with the cabin switch everything shuts off except the compressor. Last season I just turned off the AC switch in the cabin and everything shut off and I always left the breaker on. As stated last season in most cases when I got to the boat I had to hit the reset switch before it would turn on. Is there some sequence I should try. I'm heading down there today.

Blueflu
Registered user
Posts: 33
Joined: Sun Mar 06, 2016 4:33 am

Re: Aquatemp A/C compressor running nonstop

Post by Blueflu » Sat Apr 01, 2017 9:18 am

Could I have done something if I switched from dockside power to generator without shutting off the breaker. I couldn't swear I never did that but I read in a post that it could damage some components.

Blueflu
Registered user
Posts: 33
Joined: Sun Mar 06, 2016 4:33 am

Re: Aquatemp A/C compressor running nonstop

Post by Blueflu » Sun Apr 02, 2017 8:48 am

Went to the boat yesterday. Made sure the reversing valve is working, which is. I have no temperature change in the air blowing changing from AC to heat but the high and low pressure lines are properly reversing from hot to cool as I switch modes. I'm pretty familiar with house AC and reverse cycle heat pumps which is basically the same principal with the marine heat/AC units except the method of cooling it uses is water vs. a fan and ambient air temp on the home units. I didn't mention one thing, the water temperature in NJ. Its probably in the low 40's right now. I put the boat in last season in March and the heat worked but have read that heat efficiency is minimal at this temperature. I was also on a friends boat yesterday and it was pretty warm. Any chance I'm low on Freon and that's causing the compressor to stay on? I would think the opposite, it would shut down due to low pressure. Before I spend $150 for dockside service, $130 an hour labor and without parts I'd like to try to straighten this out myself first.

User avatar
prowlersfish
2018 Forum Supporter
2018 Forum Supporter
Posts: 11091
Joined: Sat Nov 05, 2005 6:56 pm
Location: Lower Chesapeake Bay ,Va

Re: Aquatemp A/C compressor running nonstop

Post by prowlersfish » Sun Apr 02, 2017 9:42 am

Low Freon is not the issue , The compressor is getting power when it should not . If you can find the relay by the Compressor try taping on it . It may unstick , Of course if it fixes it then a new relay is in order , But the fact its not heating/cooling leads me to believe you have more then 1 issue . Perhaps the compressor is bad and over loaded the relay and caused it to burn closed . Also not sure if you have 2 relays , you may Have a start and a run relay and the start is stuck causing the compressor not fully going to run ? Do you have a diagram ?
TROJAN F36 Conv.
6BTA Cummins diesels
Life is to short for a ugly boat :D
2009 TROJAN RENDEZVOUS
Port Kinsale 2010 & 2011. Solomons get together 2011.

Blueflu
Registered user
Posts: 33
Joined: Sun Mar 06, 2016 4:33 am

Re: Aquatemp A/C compressor running nonstop

Post by Blueflu » Mon Apr 03, 2017 6:15 am

Sorry, no diagram but I took some photos of the wiring in the unit. Photos are too large to attach for some reason. There's a mechanism that has an exposed spring on it and can be manipulated to "click" but it does nothing when moved. Is that what you are talking about when you say relay or are you speaking about an enclosed black type. The item I speak of has a small diameter pipe or very hard wire going into it. Not sure if it's a capillary freon line. It's behind it so I can't really see what it is or where it goes. There is certainly a connection made when I move it but nothing happens when I do. It is very similar to a connector on a home AC but the connector is what powers the unit on so it cant be that because it's running. I'm puzzled. Guess it's time for a service call.

Blueflu
Registered user
Posts: 33
Joined: Sun Mar 06, 2016 4:33 am

Re: Aquatemp A/C compressor running nonstop

Post by Blueflu » Sat Apr 22, 2017 6:37 am

I confirmed with the manufacturer that the solid state relay for the compressor was faulty and stuck in the closed position. New one on the way. That's why the compressor was turning on as soon as I turned the breaker on. Does anyone know if there would be any other symptoms from a bad relay other than that. Also can I replace the contactor on this unit. It feels like there's a small tube coming out of the back of it that I can't trace. On a home AC the connector is only electric as far as I know without any tubes. Anyone know if this is in fact a tube and if not what is it. If so where does it go.

User avatar
prowlersfish
2018 Forum Supporter
2018 Forum Supporter
Posts: 11091
Joined: Sat Nov 05, 2005 6:56 pm
Location: Lower Chesapeake Bay ,Va

Re: Aquatemp A/C compressor running nonstop

Post by prowlersfish » Sat Apr 22, 2017 10:43 am

FWIW older cruse air controls do have a tube to temp bulb
TROJAN F36 Conv.
6BTA Cummins diesels
Life is to short for a ugly boat :D
2009 TROJAN RENDEZVOUS
Port Kinsale 2010 & 2011. Solomons get together 2011.

Blueflu
Registered user
Posts: 33
Joined: Sun Mar 06, 2016 4:33 am

Re: Aquatemp A/C compressor running nonstop

Post by Blueflu » Tue May 23, 2017 9:17 am

I've been busy with work and haven't had time to play with the unit. Thanks for all the responses. I replaced the relay and now the compressor won't turn on at all. Can't seem to find the contactor or the tube to temp thing you mentioned anywhere on the internet or Aqua-Temp for that matter other than on forums. Do you think there are any compatible parts from another manufacturer available for replacement. I emailed Aqua-Air in Florida and awaiting a response. I'd hate to have to pull the unit and bring it home or drop it somewhere to get fixed.

Blueflu
Registered user
Posts: 33
Joined: Sun Mar 06, 2016 4:33 am

Re: Aquatemp A/C compressor running nonstop

Post by Blueflu » Sat Jul 15, 2017 6:31 am

A/C update. When I have time for the boat I use it and haven't really worried about the a/c because I really don't use it at all. Finally had some time to play with the system with an electrician friend. The contactor, like I said is in horrible shape. We bypassed it and the compressor came on. Am I correct in saying that the contactor starts out in the closed position, unlike a home a/c system, and when the temperature probe in the ducting system reaches the thermostat temperature the contactor opens and kills the power. Mine is open when I turn the system on and won't engage even with power to it which led me to believe it operates that way and why when I bypassed it the compressor came on. Please correct me if I'm wrong on this. Now to my second problem, warm air blowing. I have good water flow, no sweating or freezing on the piping anywhere and just some temperature changes between the high and low pressure lines. I'm sure now I need a Freon charge. Has anyone ever done this. I have the R22 and manifold set but have never done it. Any idea on the high/low pressure settings and Freon capacity. Lastly, I haven't been able to clean the fins on the condenser because I can't see or get to them so that's my next venture before I recharge. A little history on the boat. It was my brother in laws for 14 years. I know they rarely used the a/c. It sat for 2 years properly winterized and I bought it last year. A/C worked but the reset in the cabin tripped regularly. ?????????????
Is there a way to recharge it that a mechanically inclined guy like me can do it but has no HVAC experience.

User avatar
prowlersfish
2018 Forum Supporter
2018 Forum Supporter
Posts: 11091
Joined: Sat Nov 05, 2005 6:56 pm
Location: Lower Chesapeake Bay ,Va

Re: Aquatemp A/C compressor running nonstop

Post by prowlersfish » Sat Jul 15, 2017 9:04 am

I have a temp chart on the boat for cruse air . I can look it . Need air and water temps . But with that said can you Get R22 ? Do not use R22A its a cheap replacement but it is very flammable and if you have a leak (and your do if its low) it will end up in bilge . You maybe better paying someone to charge your system . If you use a "home" guy tell him to use the water temp as the outside air temp .( some don't get it )

As far as your elc issues I would need a diagram or have hands on .
TROJAN F36 Conv.
6BTA Cummins diesels
Life is to short for a ugly boat :D
2009 TROJAN RENDEZVOUS
Port Kinsale 2010 & 2011. Solomons get together 2011.

Blueflu
Registered user
Posts: 33
Joined: Sun Mar 06, 2016 4:33 am

Re: Aquatemp A/C compressor running nonstop

Post by Blueflu » Fri Aug 04, 2017 6:28 am

It's shot. I found a friend with a full 30 lb. container of R22. I charged it and it worked great....for 2 days then started blowing warm again. As a last resort I purchased a can of the best leak sealer my HVAC friend recommended and that worked for another day. Pulled the unit out to find the entire bottom of the condenser is corroded beyond repair leaking from several areas. After a day's worth of researching units on the internet I was very interested in Flagship Marine units. Electric heat not reverse cycle so it could be used on land and less moving parts. 16K BTU unit delivered was on sale for just over 2k. A little out of my price range so he recommended getting a Webasto from West Marine because of the return policy. I told him they were pricey too from what I saw and he said they are good units. Thought that was odd he was recommending West Marine and another product but I read those guys at Flagship are a family owned company and really helpful. Anyway after some searching the best deal I found a Webasto 16K was from a place in Florida delivered for $1533. Smaller footprint than the LunAire, 2 year warranty and the place was having a sale. No tax or delivery fee. Thanks to all who contributed to this thread. Maybe I'll have heat for the fall. If anyone is interested and responds I'll give an update when the install is complete.

Post Reply